Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

The 1.3 Patch for Baldur's Gate: Enhanced Edition is live! Read all about it HERE!
Icewind Dale: Enhanced Edition announced! Join the discussion HERE!
New to the forums? Well met! Please read the following rules of conduct for the forums, and we hope you enjoy your stay. Until swords part, friend!

Editing Baldur.ini file

Don't know if I am allowed to ask this question here, but I don't know where else to ask it as the old forum for BG at planetbaldursgate.com no longer exists. In my excitement about BG:EE, I dug out my 12 year old BG discs (all five of them) and installed BG. I opened the Baldur.ini file and edited it, but when I went to save it, it told me access to the file was denied. I am running Windows 7 Home Edition. Anyone know how to make it so I can edit the Baldur.ini file or know a link to the proper forum I should be asking this on?

Comments

  • YovanethYovaneth Posts: 681Member, Beta Tester
    edited November 2012
    My guess is that you've installed BG into the Program Files (x86) folder and the operating system in its infinite wisdom has tagged the file as read-only. On the baldur.ini file you can try right click | Properties | uncheck Read-Only from the Attributes section. If you're lucky then Windows 7 will obey you; if not, it will promptly make it read-only again.

    If it makes it read-only again, check the following: Control Panel | User Accounts | Change User Account Control Settings and pull the bar down to Never Notify. If you're not being bugged by the 'allow changes to the system' message each time you want to do something then the chances are this has already been done.

    A far better solution is to uninstall BG and install it somewhere else e.g. c:\MyGames\Baldur's Gate.
    Post edited by Yovaneth on
    Jenzafar
  • TanthalasTanthalas Posts: 6,738Member, Beta Tester
    Yovaneth's solution is the best, since I believe CLUAConsole also doesn't work well if the game is installed in the Program Files folder. But you should be able to edit the baldur.ini file if you have administrator rights on the computer. That or you can copy baldur-ini to another folder, make the changes that you want, and then put the file back where it was (I'm pretty sure this works).
  • bigdogchrisbigdogchris Posts: 1,334Member
    If you are on a Standard User account, you won't be able to save files to Program Files without an admin password. @Tanthalas If you are an administrator, with UAC on, you won't be able to either because the game does not prompt for UAC from within the game (while working with the console).

    The solution is to disable UAC or to install the game into a folder which does not require you to have administrator rights to edit, ie. My Documents.
  • GSMGSM Posts: 30Member
    I simply move it to the desktop > edit > save > move back

    ez pz
    Cuv
  • Yovaneth said:

    My guess is that you've installed BG into the Program Files (x86) folder and the operating system in its infinite wisdom has tagged the file as read-only. On the baldur.ini file you can try right click | Properties | uncheck Read-Only from the Attributes section. If you're lucky then Windows 7 will obey you; if not, it will promptly make it read-only again.

    If it makes it read-only again, check the following: Control Panel | User Accounts | Change User Account Control Settings and pull the bar down to Never Notify. If you're not being bugged by the 'allow changes to the system' message each time you want to do something then the chances are this has already been done.

    A far better solution is to uninstall BG and install it somewhere else e.g. c:\MyGames\Baldur's Gate.

    Thank you. I am currently installing the game in C:\MyGames\Baldur's Gate. I've always wondered why Windows 7 gives you both a Program Files and a Program Files (x86) folder. I took your advice and slid the bar down to Never Notify. That crap was always bugging me.
    Tanthalas said:

    Yovaneth's solution is the best, since I believe CLUAConsole also doesn't work well if the game is installed in the Program Files folder. But you should be able to edit the baldur.ini file if you have administrator rights on the computer. That or you can copy baldur-ini to another folder, make the changes that you want, and then put the file back where it was (I'm pretty sure this works).

    I did try that method and it let me replace the original file with the edited version, but whenever I was in game, it pressing ctrl+tab did nothing. I do have administrator rights on the computer, so that's why I was confused why it wouldn't let me edit it and I couldn't find any settings to try and edit to grant me more permissions.

    If you are on a Standard User account, you won't be able to save files to Program Files without an admin password. @Tanthalas If you are an administrator, with UAC on, you won't be able to either because the game does not prompt for UAC from within the game (while working with the console).

    The solution is to disable UAC or to install the game into a folder which does not require you to have administrator rights to edit, ie. My Documents.

    I have turned off UAC so I don't have to worry about it anymore and I installed it in a new directory.
    GSM said:

    I simply move it to the desktop > edit > save > move back

    ez pz

    That allowed me to edit the file, but nothing happened in game when I tried to activate CLUAConsole.

    ----------------

    Thanks to you guys and your suggestions, I was able to install the game and get the CLUAConsole to work. I'm not planning to do a whole lot of cheating, I really just want to give all my characters Boots of Speed, because I was quickly reminded of the fact that my biggest complaint was how slow it was walking anywhere in the game. Now if I could just figure out how to keep the game from freezing so I can create a saved game file in MP mode so I can pause the game while in my inventory. Any time I click on New Game or Load Game, the screen goes black and the game stops responding.
  • Ezzaam4FutbolEzzaam4Futbol Posts: 72Member
    The best thing possible (Feature Request incoming)
    If we could have a in-game editor(with options) letting us modify the famous baldur.ini file... For example, if we want the gore mod, we just have to check the "yes" corresponding to the feature.
    Would be simple for beginners.
  • bivbibivbi Posts: 96Member, Beta Tester
    Just another stupid things from windows 7^^ i really prefer my old win XP. It may do nothing, but at least it don't do things you wouldn't exepct/want.
  • nrqnrq Posts: 3Member
    bivbi said:

    Just another stupid things from windows 7^^ i really prefer my old win XP. It may do nothing, but at least it don't do things you wouldn't exepct/want.

    You, sir, have no idea what you are talking about.
    Good luck with your more-than-decade old OS.
  • DrakeloreDrakelore Posts: 28Member
    I am running Windows 7 Starter 32bit
    I can't seem to find Baldur.ini anywhere. I have looked in my documents, in the AppData and i the BGEE folder it self. I have tried installing the game from scratch three times now, with both the Beamdog and the stand alone installer. I have even formatted and reinstalled Windows. Can anyone help me find "baldur.ini"
  • misteridmisterid Posts: 30Member
    I know this is a really late post, but you guys are WAY off. @Drakelore, I cannot believe you reformatted and reinstalled Windows.

    1: DO NOT turn off your UAC*, it is there for a purpose and is a HUGE improvement to XP even if you don't know/understand why.

    2: Your baldur.ini is in your user "My Documents" folder, in the "Beamdog" folder. In that photo you will find BG folders and the like, go in them and find the "baldur.ini" file. Right-click on it and select the "run as administrator" selection. This will open the file in a way that can be saved.

    Id

    *This keeps many malware programs and unauthorized access to your computer's files. Turning it off will make your computer vulnerable.
  • CaremeterCaremeter Posts: 7Member
    I can't find the ini folder anywhere. I've searched high and low, i bought the BG1EE through beam dog and when i right click properties open file location there is no ini file anywhere. I simply want to console in a bag of holding for my f/m/t play through but ya im stuck..
  • optical_yetioptical_yeti Posts: 4Member
    i am also having a similar issue. I add and save the 'Debug Mode=1' text correctly in the .ini file, turn off my UAC, and when i startup the game all of my save files are gone like i just installed the game. Everything goes back to normal when i turn the UAC back on. any1 have a similar issue?
  • Eadwyn_G8keeperEadwyn_G8keeper Posts: 250Member
    edited April 3
    I am also clueless about baldur.ini file. BG1-ToSC/ Windows 7/Toshiba. I only know to access game by clicking the Skull icon and also a Baldur's Gate Configuration skull icon which deals mostly with Quick Keys. Checked "My Documents" and no such files as Beamdog. Found one for Black Isle but it has 0 bytes.

    I think I bought the game via a code purchased at Game Stop. I do not have to be on WiFi to play so it is all somewhere in my computer.

    All I want to do is create "Knock" scroll if one hasn't turned up before Bandit Camp on this playthrough.
    Post edited by Eadwyn_G8keeper on
  • KelledonKelledon Posts: 1Member
    Hi all I did what GSM suggested and I moved the baldur.ini file for the Old Baldur's Gate 2: Shadows of Amn to the desktop and edited it there and than moved it back to it's orginal folder, I'm running Windows 7 by the way. But unlike them I was able to activate the CLUAConsole in game but the problem I'm now having is that the game is coming up with and error message whenever I try to save it after having created scrolls for my Mage and other gear and it says save successful in game but when I go to load it up it acts like I haven't done anything at all. I really don't know how to solve this problem at all.
Sign In or Register to comment.